Календарь планирования: шаг 2

календарь проектовПродолжаем разбирать как сделать календарь планирования. Шаг 1 мы уже сделали, оформили сам календрь. Осталось сделать второй шаг - сформировать график, используя различные цвета, чтобы понимать какие сроки даются на тот или иной этап и какие контрольные точки.

Итак, продолжаем осваивать Excel.

Шаг 2. Формирование диаграммы Ганта

(конечно, в буквальном смысле сказать, что это диаграмма Ганта нельзя сказать, но общим вид и смысл очень похожи)

Напомним, что в шаге 1 был сформирован календарь. Продолжаем с ним работать.

Выделяем ячейки с С3:AG12. На вкладке Главная группы Стили выбрать команду Условное формативание, в открывшемся меню выбрать команду Создать правило.

календарь планирования

В открывшемся диалоговом окне Создание правила форматирования в разделе "Выберите тип правила" кликните по пункту "Использовать формулу для определения форматируемых ячеек" В поле ниже необходимо ввести формулу (не забываем про правила ввода формул): =СУММПРОИЗВ((C4>=$AJ$4:$AJ$13)*(C4<=$AK$4:$AK$13))=1. Нажатие кнопки Формат позволяет выбрат цвет ячейки, который будет применяться к тем ячейкам календаря, которые удовлетворяют заданному условию.

календарь проектов

Теперь про само условие, что оно обозначает. Данная формула сравнивает данные каждой ячейки календаря с датой, указанной в таблице этапов. Другими словами, формула начиная с С4 и до ячейки AG12 сранивает дату этапа и закрашивает ячейку если дата этапа попадает в календарь. В конце единица обозначет, что если оба условия в скобках выполняются, значит закрашиваем ячейки, если не выполняется условие, значит ячейка остается без цвета. При этот обратите внимание, что в формуле присутствует абсолютная ссылка (значок $), что это обозначает и зачем это использовать мы писали в шаге 1.

Наш календарь будет выглядеть следующим образом:

календарь проектов

Примечание: количество этапов можно регулировать и даже сделать пустные ячейки, адреса которыхе указывать в формуле. Это удобно в том плане, что если добавится этап (даты начала и окончания), то это сразу отразиться в календаре.

Заметим, что некоторые этапы могут пересекаться, и это следует отразить в календаре. Для этого снова выделяем наш диапазон С3:AG12, создаем новое правило по аналогии, как описывалось выше, формула будет такая же за исключением одного, в конце вместо "=1" ставим ">1". И выбираем другой цвет заливки ячейки.

календарь проектов

Вот и готов наш календарь. Теперь можно ориентироваться по этапам и понимать, когда что запланировано.

СДЕЛАЙТЕ ДОБРОЕ ДЕЛО, ПОДЕЛИТЕСЬ С ДРУЗЬЯМИ

Добавить комментарий


Защитный код
Обновить