Фишки в Excel: секрет 4. Выборочное суммирование

Чаще всего мы пользуемся возможностями программы Microsoft Word, но время от времени нам приходится обращаться и к Microsoft Excel. В основном это 5% от ее возможностей, но не стоит так бояться таблиц и формул. На самом деле это программа скрывает в себе огромное количество секретов, раскрыв которые можно облегчить себе работу, автоматизировать расчеты и многое другое.

Раскроем небольшие секреты MS Excel, которые могут быть полезны для бизнеса.

Секрет 4. Выборочное суммирование

Суть выборочного суммирования заключается в том, чтобы подсчитать общую сумму, на которую определенный заказчик купил определенный товар. Другими словами создать удобную расчетную таблицу. Например, нам дана таблица, состоящая из трех столбцов: фамилия заказчика, тип товара (№1 или №2) и сумма. Нам требуется выяснить: на какую сумму заказчик Иванов купил товара типа №2.

В данном примере таблица небольшая, но она может быть любого размера с любым количеством данных.

Рядом с таблицей построит небольшую табличку, в которой будут отражаться нужные нам значения:

 

  • В ячейку F4 вводим формулу =А3, чтобы отображалась нужная нам фамилия.
  • В ячейку F5 вводим формулу =В3, чтобы отображался нужный нам тип товара.
  • В ячейку F6 вводим формулу =СУММ((A3:A10=F4)*(B3:B10=F5)*C3:C10). Разберем ее по шагам:
    • Вводим =СУММ(). В скобках будет три множителя, знак умножения ставится символом *.
    • Первый множитель. Открываем скобку и с помощью мыши выделяем диапазон A3:A10, ставим знак = и щелкаем с помощью мыши в ячейку F4, закрываем скобки. Должна появиться надпись: (A3:A10=F4). Таким образом, мы указываем, что из нужного нам диапазона столбца А необходимо выбрать фамилию Иванов.
    • Второй множитель. Открываем скобку и с помощью мыши выделяем диапазон В3:В10, ставим знак = и щелкаем с помощью мыши в ячейку F5, закрываем скобки. Должна появиться надпись: (В3:В10=F5). Таким образом, мы указываем, что из нужного нам диапазона столбца В необходимо выбрать тип товара №1.
    • Третий множитель (его в скобки не заключаем). С помощью мыши выделяем диапазон С3:С10. Должна появиться надпись: С3:С10. Таким образом, мы указываем, что из нужного нам диапазона столбца С необходимо подсчитать общую сумму, удовлетворяющую указанным условиям.
  • Вместо клавиши Enter нажимаем комбинацию клавиш Ctrl + Shift + Enter.

Можно немного усовершенствовать вторую таблицу и создать раскрывающийся список в строках Заказчик и Тип товара (ячейки F4 и F5). Более подробно об этом написано в уроке "Раскрывающийся список в MS Excel". Тогда можно будет выбирать данные Заказчик и Тип товара из списка.

СДЕЛАЙТЕ ДОБРОЕ ДЕЛО, ПОДЕЛИТЕСЬ С ДРУЗЬЯМИ

Добавить комментарий


Защитный код
Обновить