Фишки в Excel: секрет 3. Запрет на ввод повторных записей

Чаще всего мы пользуемся возможностями программы Microsoft Word, но время от времени нам приходится обращаться и к Microsoft Excel. В основном это 5% от ее возможностей, но не стоит так бояться таблиц и формул. На самом деле это программа скрывает в себе огромное количество секретов, раскрыв которые можно облегчить себе работу, автоматизировать расчеты и многое другое. Используйте автозаполнение ячеек для быстро ввода, создайте формулы для расчетов, отчетные таблицы для быстро создания отчетных форм.

Раскроем небольшие секреты MS Excel, которые могут быть полезны для бизнеса.

Секрет 3. Запрет на ввод повторных записей

Предположим, что перед нами задача – создать прайс-лист. Нам необходимо установить запрет на повторяющиеся записи, то есть сделать так, чтобы данные в списке не повторялись. Для примера мы рассмотрим 10 записей, на самом деле их может быть сколько угодно.

Перед тем как составлять список, подготовим ячейки в таблице для этого проделаем следующие шаги:

  • Выделить диапазон ячеек, на которые будет распространяться запрет (в нашем примере это А1:А10).
  • На вкладке Данные группы Работа с данными выбрать команду Проверка данных.
  • В появившемся диалоговом окне Проверка вводимых значений выбрать в поле Тип данныхДругой.
  • Поле Формула заполняем следующим образом: =СЧЁТЕСЛИ($A$1:$A$10;A1)<=1. Если вы носите данные вручную, то обратите внимание на то, что адреса ячеек A1:A10 записываются на английском языке.

  • В этом же диалоговом окне на вкладке Сообщение об ошибке вводим текст, который будет появляться при попытке ввести повторные данные, например, заголовок - «Ошибка ввода!», текст – «Такие записи уже присутствуют в таблице».

 

  • Нажать ОК.

СДЕЛАЙТЕ ДОБРОЕ ДЕЛО, ПОДЕЛИТЕСЬ С ДРУЗЬЯМИ

Добавить комментарий


Защитный код
Обновить